What’s Vulnerable › Vulnerabilities
CVE-2024-9796: WP-Advanced-Search < 3.3.9.2 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-10 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP-Advanced-Search WordPress plugin before 3.3.9.2 does not sanitize and escape the t parameter before using it in a SQL statement, allowing unauthenticated users to perform SQL injection attacks
Affected products
- Mathieu Chartier WordPress WP-Advanced-Search: before 3.3.9.2 — fixed in 3.3.9.2
How to fix
Upgrade to a fixed version: Mathieu Chartier WordPress WP-Advanced-Search 3.3.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9796 or the next vulnerability affects your stack