What’s Vulnerable › Vulnerabilities
CVE-2024-9820: WP 2FA with Telegram <= 3.0 - Two-Factor Authentication Bypass
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-15 · updated 2026-06-17
- Weakness: CWE-784
Description
The WP 2FA with Telegram plugin for WordPress is vulnerable to Two-Factor Authentication Bypass in versions up to, and including, 3.0. This is due to the two-factor code being stored in a cookie, which makes it possible to bypass two-factor authentication.
Affected products
- dueclic Wp 2Fa With Telegram: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: dueclic Wp 2Fa With Telegram 3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/two-factor-login-telegram/tags/3.0/includes/class-wp-factor-telegram-plugin.php#L228
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ccd73030-7185-4302-b3fd-29cbbe716e3e?source=cve
Get alerted when CVE-2024-9820 or the next vulnerability affects your stack