What’s Vulnerable › Vulnerabilities
CVE-2024-9829: Download Plugin <= 2.2.0 - Missing Authorization to Authenticated (Subscriber+) User Metadata and Comment Download
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-23 · updated 2026-06-17
- Weakness: CWE-862
Description
The Download Plugin plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability checks on the 'dpwap_handle_download_user' and 'dpwap_handle_download_comment' functions in all versions up to, and including, 2.2.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to download any comment, and download metadata for any user including user PII and sensitive information including username, email, hashed passwords and application passwords, session token information and more depending on set up and additional plugins installed.
Affected products
- metagauss Download Plugin: before 2.2.1 — fixed in 2.2.1
How to fix
Upgrade to a fixed version: metagauss Download Plugin 2.2.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/download-plugin/trunk/download-plugin.php#L242
- https://plugins.trac.wordpress.org/browser/download-plugin/trunk/download-plugin.php#L262
- https://plugins.trac.wordpress.org/browser/download-plugin/trunk/download-plugin.php#L335
- https://plugins.trac.wordpress.org/changeset/3170600/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e0891211-e4b3-4dcf-8ee0-e20abeb91640?source=cve
Get alerted when CVE-2024-9829 or the next vulnerability affects your stack