What’s Vulnerable › Vulnerabilities
CVE-2024-9835: RSS Feed Widget < 3.0.1 - Reflected XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The RSS Feed Widget WordPress plugin before 3.0.1 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers
Affected products
- fahadmahmood RSS Feed Widget: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: fahadmahmood RSS Feed Widget 3.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9835 or the next vulnerability affects your stack