What’s Vulnerable › Vulnerabilities
CVE-2024-9847: Cross-Site Request Forgery (CSRF) in flatpressblog/flatpress
- Severity: high (CVSS 8.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-352
Description
FlatPress CMS version latest is vulnerable to Cross-Site Request Forgery (CSRF) attacks that allow an attacker to enable or disable plugins on behalf of a victim user. The attacker can craft a malicious link or script that, when clicked by an authenticated user, will send a request to the FlatPress CMS server to perform the desired action on behalf of the victim user. Since the request is authenticated, the server will process it as if it were initiated by the legitimate user, effectively allowing the attacker to perform unauthorized actions. This vulnerability is fixed in version 1.4.dev.
Affected products
- flatpressblog/flatpress: before 1.4 — fixed in 1.4
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.4. Check the vendor advisory for mitigations.
References
- https://github.com/flatpressblog/flatpress/commit/a81c968f51f134b5e5f9bbe208aa12f4fbc329df
- https://huntr.com/bounties/b30ef7b0-74ea-4cac-adc4-1cc8a5cb559e
Get alerted when CVE-2024-9847 or the next vulnerability affects your stack