What’s Vulnerable › Vulnerabilities
CVE-2024-9858: Insecure user permissions in Google Cloud Migrate to Containers for Windows
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-276
Description
There exists an insecure default user permission in Google Cloud Migrate to containers from version 1.1.0 to 1.2.2 Windows installs. A local "m2cuser" was greated with administrator privileges. This posed a security risk if the "analyze" or "generate" commands were interrupted or skipping the action to delete the local user “m2cuser”. We recommend upgrading to 1.2.3 or beyond
Affected products
- Google Cloud Migrate to Containers: from 1.1.0 before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: Google Cloud Migrate to Containers 1.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9858 or the next vulnerability affects your stack