What’s Vulnerable › Vulnerabilities
CVE-2024-9861: Miniorange OTP Verification with Firebase <= 3.6.0 - Authentication Bypass
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-17 · updated 2026-06-17
- Weakness: CWE-288
Description
The Miniorange OTP Verification with Firebase plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.6.0. This is due to missing validation on the token being supplied during the otp login through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they know the phone number associated with that user.
Affected products
- cyberlord92 Miniorange OTP Verification with Firebase: before 3.6.1 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: cyberlord92 Miniorange OTP Verification with Firebase 3.6.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/miniorange-firebase-sms-otp-verification/tags/3.6.0/handler/forms/class-loginform.php#L144
- https://plugins.trac.wordpress.org/browser/miniorange-firebase-sms-otp-verification/tags/3.6.0/handler/forms/class-loginform.php#L190
- https://plugins.trac.wordpress.org/changeset/3169869/miniorange-firebase-sms-otp-verification#file3
- https://www.wordfence.com/threat-intel/vulnerabilities/id/04045ec3-dd8e-4ac5-bd73-eef6205ecc62?source=cve
Get alerted when CVE-2024-9861 or the next vulnerability affects your stack