What’s Vulnerable › Vulnerabilities
CVE-2024-9870: Unintended Proxy or Intermediary ('Confused Deputy') in GitLab
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-441
Description
An external service interaction vulnerability in GitLab EE affecting all versions from 15.11 prior to 17.6.5, 17.7 prior to 17.7.4, and 17.8 prior to 17.8.2 allows an attacker to send requests from the GitLab server to unintended services.
Affected products
- GitLab: from 15.11.0 before 17.6.5; from 17.7.0 before 17.7.4; from 17.8.0 before 17.8.2 — fixed in 17.6.5, 17.7.4, 17.8.2
How to fix
Upgrade to a fixed version: GitLab 17.6.5, 17.7.4, 17.8.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9870 or the next vulnerability affects your stack