What’s Vulnerable › Vulnerabilities
CVE-2024-9883: Pods < 3.2.7.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Pods WordPress plugin before 3.2.7.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- sc0ttkclark Pods – Custom Content Types and Fields: before 3.2.7.1 — fixed in 3.2.7.1
How to fix
Upgrade to a fixed version: sc0ttkclark Pods – Custom Content Types and Fields 3.2.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-9883 or the next vulnerability affects your stack