What’s Vulnerable › Vulnerabilities
CVE-2024-9889: ElementInvader Addons for Elementor <= 1.2.9 - Authenticated (Contributor+) Information Exposure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-19 · updated 2026-06-17
- Weakness: CWE-200
Description
The ElementInvader Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.2.9 via the Page Loader widget. This makes it possible for authenticated attackers, with contributor-level access and above, to view private/draft/password protected posts, pages, and Elementor templates that they should not have access to.
Affected products
- Element Invader ElementInvader Addons for Elementor: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Element Invader ElementInvader Addons for Elementor 1.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3171339%40elementinvader-addons-for-elementor&new=3171339%40elementinvader-addons-for-elementor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9bd04f78-0b9c-4985-b450-007bb5cc9e26?source=cve
Get alerted when CVE-2024-9889 or the next vulnerability affects your stack