What’s Vulnerable › Vulnerabilities
CVE-2024-9892: Add Widget After Content <= 2.4.6 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Add Widget After Content plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- apintop Add Widget After Content: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: apintop Add Widget After Content 2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/add-widget-after-content/trunk/add-widget-after-content-admin.php#L320
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3170427%40add-widget-after-content&new=3170427%40add-widget-after-content&sfp_email=&sfph_mail=
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3170428%40add-widget-after-content&new=3170428%40add-widget-after-content&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e02472a8-5b88-43ad-86f3-e890b49899ad?source=cve
Get alerted when CVE-2024-9892 or the next vulnerability affects your stack