What’s Vulnerable › Vulnerabilities
CVE-2024-9898: Parallax Image <= 1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via dd-parallax Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Parallax Image plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's dd-parallax shortcode in all versions up to, and including, 1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- thehowarde Parallax Image: before 1.9 — fixed in 1.9
How to fix
Upgrade to a fixed version: thehowarde Parallax Image 1.9. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/parallax-image/trunk/assets/shortcode.php#L145
- https://plugins.trac.wordpress.org/changeset/3170176/
- https://plugins.trac.wordpress.org/changeset/3170176/#file16
- https://wordpress.org/plugins/parallax-image/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/57641366-85d3-4375-8cde-041227c9f811?source=cve
Get alerted when CVE-2024-9898 or the next vulnerability affects your stack