What’s Vulnerable › Vulnerabilities
CVE-2024-9927: WooCommerce Order Proposal <= 2.0.5 - Authenticated (Shop Manager+) Privilege Escalation via Order Proposal
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-23 · updated 2026-06-17
- Weakness: CWE-287
Description
The WooCommerce Order Proposal plugin for WordPress is vulnerable to privilege escalation via order proposal in all versions up to and including 2.0.5. This is due to the improper implementation of allow_payment_without_login function. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to log in to WordPress as an arbitrary user account, including administrators.
Affected products
- WP Overnight BV WooCommerce Order Proposal: before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: WP Overnight BV WooCommerce Order Proposal 2.0.6. Check the vendor advisory for mitigations.
References
- https://wpovernight.com/downloads/woocommerce-order-proposal/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cdc993a4-6f65-4570-811c-13a80dbec064?source=cve
Get alerted when CVE-2024-9927 or the next vulnerability affects your stack