What’s Vulnerable › Vulnerabilities
CVE-2024-9941: WPGYM <= 67.1.0 - Missing Authorization to Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-23 · updated 2026-06-17
- Weakness: CWE-269
Description
The WPGYM - Wordpress Gym Management System plugin for WordPress is vulnerable to privilege escalation due to a missing capability check on the MJ_gmgt_add_staff_member() function in all versions up to, and including, 67.1.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to create new user accounts with the administrator role.
Affected products
- dasinfomedia WPGYM - Wordpress Gym Management System: before 67.2.0 — fixed in 67.2.0
How to fix
Upgrade to a fixed version: dasinfomedia WPGYM - Wordpress Gym Management System 67.2.0. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/-wpgym-wordpress-gym-management-system/13352964
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cbff92c1-8492-4d0d-bd90-8fd33625bf6f?source=cve
Get alerted when CVE-2024-9941 or the next vulnerability affects your stack