What’s Vulnerable › Vulnerabilities
CVE-2024-9943: MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution <= 4.2.4 - Cross-Site Request Forgery to Vendor Updates
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-352
Description
The MultiVendorX – The Ultimate WooCommerce Multivendor Marketplace Solution plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.4. This is due to missing or incorrect nonce validation on several functions in api/class-mvx-rest-controller.php. This makes it possible for unauthenticated attackers to update vendor account details, create vendor accounts, and delete arbitrary users via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- MultiVendorX: before 4.2.5 — fixed in 4.2.5
How to fix
Upgrade to a fixed version: MultiVendorX 4.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L5258
- https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L6009
- https://plugins.trac.wordpress.org/browser/dc-woocommerce-multi-vendor/tags/4.2.1/api/class-mvx-rest-controller.php#L6155
- https://plugins.trac.wordpress.org/changeset/3173238/dc-woocommerce-multi-vendor/trunk/api/class-mvx-rest-controller.php?old=3168957&old_path=dc-woocommerce-multi-vendor%2Ftrunk%2Fapi%2Fclass-mvx-rest-controller.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b950faf9-2122-42af-9f05-ec850767be32?source=cve
Get alerted when CVE-2024-9943 or the next vulnerability affects your stack