What’s Vulnerable › Vulnerabilities
CVE-2024-9944: WooCommerce <= 9.0.2 - Unauthenticated HTML Injection
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The WooCommerce plugin for WordPress is vulnerable to HTML Injection in all versions up to, and including, 9.0.2. This is due to the plugin not properly neutralizing HTML elements from submitted order forms. This makes it possible for unauthenticated attackers to inject arbitrary HTML that will render when the administrator views order form submissions.
Affected products
- Automattic WooCommerce: before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: Automattic WooCommerce 9.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/woocommerce/woocommerce/pull/49370
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3115837%40woocommerce%2Ftrunk&old=3106873%40woocommerce%2Ftrunk&sfp_email=&sfph_mail=
- https://raw.githubusercontent.com/woocommerce/woocommerce/trunk/changelog.txt
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b5dfe2a5-612f-4e6c-a639-4afcff2ffa4c?source=cve
Get alerted when CVE-2024-9944 or the next vulnerability affects your stack