What’s Vulnerable › Vulnerabilities
CVE-2024-9946: Social Share, Social Login and Social Comments Plugin – Super Socializer <= 7.13.68 - Authentication Bypass via Disqus OAuth provider
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-287
Description
The Social Share, Social Login and Social Comments Plugin – Super Socializer plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 7.13.68. This is due to insufficient verification on the user being returned by the social login token. This makes it possible for unauthenticated attackers to log in as any existing user on the site, if they have access to the email and the user does not have an already-existing account for the service returning the token. An attacker cannot authenticate as an administrator by default, but these accounts are also at risk if authentication for administrators has explicitly been allowed via the social login. The vulnerability was partially patched in version 7.13.68.
Affected products
- the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer: before 7.14 — fixed in 7.14
How to fix
Upgrade to a fixed version: the_champ Social Share, Social Login and Social Comments Plugin – Super Socializer 7.14. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3172935/
- https://plugins.trac.wordpress.org/changeset/3180581/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c394b8b6-b7f6-4ba7-8a2b-98160cc286a8?source=cve
Get alerted when CVE-2024-9946 or the next vulnerability affects your stack