What’s Vulnerable › Vulnerabilities
CVE-2025-0110: PAN-OS OpenConfig Plugin: Command Injection Vulnerability in OpenConfig Plugin
- Severity: high (CVSS 8.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability in the Palo Alto Networks PAN-OS OpenConfig plugin enables an authenticated administrator with the ability to make gNMI requests to the PAN-OS management web interface to bypass system restrictions and run arbitrary commands. The commands are run as the “__openconfig” user (which has the Device Administrator role) on the firewall. You can greatly reduce the risk of this issue by restricting access to the management web interface to only trusted internal IP addresses according to our recommended best practices deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 .
Affected products
- Palo Alto Networks PAN-OS OpenConfig Plugin: from 1.0.0 before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS OpenConfig Plugin 2.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0110 or the next vulnerability affects your stack