What’s Vulnerable › Vulnerabilities
CVE-2025-0115: PAN-OS: Authenticated Admin File Read Vulnerability in PAN-OS CLI
- Severity: medium (CVSS 6.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-41
Description
A vulnerability in the Palo Alto Networks PAN-OS software enables an authenticated admin on the PAN-OS CLI to read arbitrary files. The attacker must have network access to the management interface (web, SSH, console, or telnet) and successfully authenticate to exploit this issue. You can greatly reduce the risk of this issue by restricting access to the management interface to only trusted users and internal IP addresses according to our recommended critical deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue does not affect Cloud NGFW or Prisma Access.
Affected products
- Palo Alto Networks PAN-OS: from 11.2.0 before 11.2.3; from 11.1.0 before 11.1.5; from 11.0.0 before 11.0.6; from 10.2.0 before 10.2.11; from 10.1.0 before 10.1.14-h11 — fixed in 10.1.14-h11, 10.2.11, 11.0.6, 11.1.5, 11.2.3
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.14-h11, 10.2.11, 11.0.6, 11.1.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0115 or the next vulnerability affects your stack