What’s Vulnerable › Vulnerabilities
CVE-2025-0118: GlobalProtect App: Execution of Unsafe ActiveX Control Vulnerability
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-06-17
- Weakness: CWE-618
Description
A vulnerability in the Palo Alto Networks GlobalProtect app on Windows allows a remote attacker to run ActiveX controls within the context of an authenticated Windows user. This enables the attacker to run commands as if they are a legitimate authenticated user. However, to exploit this vulnerability, the authenticated user must navigate to a malicious page during the GlobalProtect SAML login process on a Windows device. This issue does not apply to the GlobalProtect app on other (non-Windows) platforms.
Affected products
- Palo Alto Networks GlobalProtect App: from 6.0.0 before 6.0.11; from 6.1.0 before 6.1.6; from 6.2.0 before 6.2.5; from 6.3.0 before 6.3.3 — fixed in 6.0.11, 6.1.6, 6.2.5, 6.3.3
- Palo Alto Networks GlobalProtect App: from 6.2.0 before 6.2.5; from 6.1.0 before 6.1.6; from 6.0.0 before 6.0.11 — fixed in 6.2.5, 6.1.6, 6.0.11
How to fix
Upgrade to a fixed version: Palo Alto Networks GlobalProtect App 6.0.11, 6.1.6, 6.2.5, 6.3.3; Palo Alto Networks GlobalProtect App 6.2.5, 6.1.6, 6.0.11. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0118 or the next vulnerability affects your stack