What’s Vulnerable › Vulnerabilities
CVE-2025-0123: PAN-OS: Information Disclosure Vulnerability in HTTP/2 Packet Captures
- Severity: medium (CVSS 5.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-312
Description
A vulnerability in the Palo Alto Networks PAN-OS® software enables unlicensed administrators to view clear-text data captured using the packet capture feature https://docs.paloaltonetworks.com/pan-os/11-0/pan-os-admin/monitoring/take-packet-captures/take-a-custom-packet-capture in decrypted HTTP/2 data streams traversing network interfaces on the firewall. HTTP/1.1 data streams are not impacted. In normal conditions, decrypted packet captures are available to firewall administrators after they obtain and install a free Decryption Port Mirror license. The license requirement ensures that this feature can only be used after approved personnel purposefully activate the license. For more information, review how to configure decryption port mirroring https://docs.paloaltonetworks.com/network-security/decryption/administration/monitoring-decryption/configure-decryption-port-mirroring . The administrator must obtain network access to the management interface (web, SSH, console, or telnet) and successfully authenticate to exploit this issue. Risk of this issue can be greatly reduced by restricting access to the management interface to only trusted administrators and from only internal IP addresses according to our recommended critical deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . Customer firewall administrators do not have access to the packet capture feature in Cloud NGFW. This feature is available only to authorized Palo Alto Networks personnel permitted to perform troubleshooting. Prisma® Access is not impacted by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 11.2.0 before 11.2.6; from 11.1.0 before 11.1.8; from 10.2.0 before 10.2.15; from 10.1.0 before 10.1.14-h13 — fixed in 10.1.14-h13, 10.2.15, 11.1.8, 11.2.6
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.14-h13, 10.2.15, 11.1.8, 11.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0123 or the next vulnerability affects your stack