What’s Vulnerable › Vulnerabilities
CVE-2025-0127: PAN-OS: Authenticated Admin Command Injection Vulnerability in PAN-OS VM-Series
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-11 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability in Palo Alto Networks PAN-OS® software enables an authenticated administrator to bypass system restrictions and run arbitrary commands as a root user. This issue is only applicable to PAN-OS VM-Series. This issue does not affect firewalls that are already deployed. Cloud NGFW and Prisma® Access are not affected by this vulnerability.
Affected products
- Palo Alto Networks PAN-OS: from 11.0.0 before 11.0.4; from 10.2.0 before 10.2.9; from 10.1.0 before 10.1.14-h13 — fixed in 10.1.14-h13, 10.2.9, 11.0.4
How to fix
Upgrade to a fixed version: Palo Alto Networks PAN-OS 10.1.14-h13, 10.2.9, 11.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0127 or the next vulnerability affects your stack