What’s Vulnerable › Vulnerabilities

CVE-2025-0160: IBM FlashSystem code execution

Description

IBM FlashSystem (IBM Storage Virtualize (8.5.0.0 through 8.5.0.13, 8.5.1.0, 8.5.2.0 through 8.5.2.3, 8.5.3.0 through 8.5.3.1, 8.5.4.0, 8.6.0.0 through 8.6.0.5, 8.6.1.0, 8.6.2.0 through 8.6.2.1, 8.6.3.0, 8.7.0.0 through 8.7.0.2, 8.7.1.0, 8.7.2.0 through 8.7.2.1) could allow a remote attacker with access to the system to execute arbitrary Java code due to improper restrictions in the RPCAdapter service.

Affected products

How to fix

Upgrade to a fixed version: IBM Storage Virtualize 8.5.0.14, 8.6.0.6, 8.7.0.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0160 or the next vulnerability affects your stack