What’s Vulnerable › Vulnerabilities
CVE-2025-0165: IBM watsonx Orchestrate Cartridge for IBM Cloud Pak for Data SQL injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-30 · updated 2026-10-18
- Weakness: CWE-89
Description
IBM watsonx Orchestrate Cartridge for IBM Cloud Pak for Data 4.8.4, 4.8.5, and 5.0.0 through 5.2.0 is vulnerable to SQL injection. A remote attacker could send specially crafted SQL statements, which could allow the attacker to view, add, modify, or delete information in the back-end database.
Affected products
- IBM watsonx Orchestrate Cartridge for IBM Cloud Pak for Data: from 4.8.4 through 4.8.5; from 5.0.0 before 5.2.0.1 — fixed in 5.2.0.1
How to fix
Upgrade to a fixed version: IBM watsonx Orchestrate Cartridge for IBM Cloud Pak for Data 5.2.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0165 or the next vulnerability affects your stack