What’s Vulnerable › Vulnerabilities
CVE-2025-0169: DWT - Directory & Listing WordPress Theme <=3.3.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The DWT - Directory & Listing WordPress Theme is vulnerable to Stored Cross-Site Scripting via shortcodes in versions up to, and including, 3.3.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- scriptsbundle DWT - Directory & Listing WordPress Theme: before 3.3.5 — fixed in 3.3.5
How to fix
Upgrade to a fixed version: scriptsbundle DWT - Directory & Listing WordPress Theme 3.3.5. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/dwt-listing-directory-listing-wordpress-theme/21976132
- https://www.wordfence.com/threat-intel/vulnerabilities/id/be0c29a3-0b78-4259-a514-c3674d9d5d55?source=cve
Get alerted when CVE-2025-0169 or the next vulnerability affects your stack