What’s Vulnerable › Vulnerabilities
CVE-2025-0177: Javo Core <= 3.0.0.080 - Unauthenticated Privilege Escalation in ajax_signup
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-08 · updated 2026-06-17
- Weakness: CWE-269
Description
The Javo Core plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 3.0.0.080. This is due to the plugin allowing users who are registering new accounts to set their own role. This makes it possible for unauthenticated attackers to gain elevated privileges by creating an account with the administrator role.
Affected products
- javothemes Javo Core: before 3.0.0.266 — fixed in 3.0.0.266
How to fix
Upgrade to a fixed version: javothemes Javo Core 3.0.0.266. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/javo-directory-wordpress-theme/8390513#item-description__update-history
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7d636768-37b4-4343-9028-30e7b1f997f2?source=cve
Get alerted when CVE-2025-0177 or the next vulnerability affects your stack