What’s Vulnerable › Vulnerabilities

CVE-2025-0194: Insertion of Sensitive Information into Externally-Accessible File or Directory in GitLab

Description

An issue was discovered in GitLab CE/EE affecting all versions starting from 17.4 prior to 17.5.5, starting from 17.6 prior to 17.6.3, and starting from 17.7 prior to 17.7.1. Under certain conditions, access tokens may have been logged when API requests were made in a specific manner.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.5.5, 17.6.3, 17.7.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0194 or the next vulnerability affects your stack