What’s Vulnerable › Vulnerabilities
CVE-2025-0237: WebChannel APIs susceptible to confused deputy attack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-10-05
- Weakness: CWE-863
Description
The WebChannel API, which is used to transport various information across processes, did not check the sending principal but rather accepted the principal being sent. This could have led to privilege escalation attacks. This vulnerability was fixed in Firefox 134, Firefox ESR 128.6, Thunderbird 134, and Thunderbird 128.6.
Affected products
- Mozilla Firefox: before 128.6.0; before 134.0 — fixed in 128.6.0, 134.0
- Mozilla Thunderbird: before 128.6.0; from 129.0 before 134.0 — fixed in 128.6.0, 134.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 128.6.0, 134.0; Mozilla Thunderbird 128.6.0, 134.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1915257
- https://www.mozilla.org/security/advisories/mfsa2025-01/
- https://www.mozilla.org/security/advisories/mfsa2025-02/
- https://www.mozilla.org/security/advisories/mfsa2025-04/
- https://www.mozilla.org/security/advisories/mfsa2025-05/
- https://lists.debian.org/debian-lts-announce/2025/01/msg00004.html
Get alerted when CVE-2025-0237 or the next vulnerability affects your stack