What’s Vulnerable › Vulnerabilities
CVE-2025-0281: Stored Cross-Site Scripting (XSS) in lunary-ai/lunary
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in lunary-ai/lunary versions 1.6.7 and earlier. An attacker can inject malicious JavaScript into the SAML IdP XML metadata, which is used to generate the SAML login redirect URL. This URL is then set as the value of `window.location.href` without proper validation or sanitization. This vulnerability allows the attacker to execute arbitrary JavaScript in the context of the user's browser, potentially leading to session hijacking, data theft, or other malicious actions. The issue is fixed in version 1.7.10.
Affected products
- lunary-ai/lunary: before 1.7.10 — fixed in 1.7.10
How to fix
Upgrade to a fixed version: lunary-ai/lunary 1.7.10. Check the vendor advisory for mitigations.
References
- https://github.com/lunary-ai/lunary/commit/fa0fd7742ae029ed934690d282519263f5d838de
- https://huntr.com/bounties/b3f4a655-5b08-4fef-be2c-aac8703ad5d0
Get alerted when CVE-2025-0281 or the next vulnerability affects your stack