What’s Vulnerable › Vulnerabilities

CVE-2025-0314: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 17.2 before 17.6.4, 17.7 before 17.7.3, and 17.8 before 17.8.1. Improper rendering of certain file types lead to cross-site scripting.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.6.4, 17.7.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0314 or the next vulnerability affects your stack