What’s Vulnerable › Vulnerabilities
CVE-2025-0350: Divi Carousel Lite <= 2.0.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Image Carousel and Logo Carousel Widgets
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Divi Carousel Maker – Image, Logo, Testimonial, Post Carousel & More plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Image Carousel and Logo Carousel in all versions up to, and including, 2.0.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- badhonrocks Divi Carousel Free (Divi5 Support): before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: badhonrocks Divi Carousel Free (Divi5 Support) 2.1.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wow-carousel-for-divi-lite/trunk/includes/divi4/modules/ImageCarouselChild/ImageCarouselChild.php#L327
- https://plugins.trac.wordpress.org/browser/wow-carousel-for-divi-lite/trunk/includes/divi4/modules/LogoCarouselChild/LogoCarouselChild.php#L168
- https://plugins.trac.wordpress.org/changeset/3226742/
- https://wordpress.org/plugins/wow-carousel-for-divi-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9e57a85b-3ea8-46df-ab60-ce835268b1f6?source=cve
Get alerted when CVE-2025-0350 or the next vulnerability affects your stack