What’s Vulnerable › Vulnerabilities
CVE-2025-0357: WPBookit <= 1.6.9 - Unauthenticated Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-25 · updated 2026-06-17
- Weakness: CWE-434
Description
The WPBookit plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'WPB_Profile_controller::handle_image_upload' function in versions up to, and including, 1.6.9. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected site's server which may make remote code execution possible.
Affected products
- iqonicdesign WPBookit: before 1.6.10 — fixed in 1.6.10
How to fix
Upgrade to a fixed version: iqonicdesign WPBookit 1.6.10. Check the vendor advisory for mitigations.
References
- https://documentation.iqonic.design/wpbookit/versions/change-log
- https://www.wordfence.com/threat-intel/vulnerabilities/id/19bf7a68-e76d-4740-9f35-b6084094f59b?source=cve
Get alerted when CVE-2025-0357 or the next vulnerability affects your stack