What’s Vulnerable › Vulnerabilities

CVE-2025-0362: Improper Restriction of Rendered UI Layers or Frames in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 7.7 before 17.8.7, 17.9 before 17.9.6, and 17.10 before 17.10.4. Under certain conditions, an attacker could potentially trick users into unintentionally authorizing sensitive actions on their behalf.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.4, 17.8.7, 17.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0362 or the next vulnerability affects your stack