What’s Vulnerable › Vulnerabilities

CVE-2025-0376: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An XSS vulnerability exists in GitLab CE/EE affecting all versions from 13.3 prior to 17.6.5, 17.7 prior to 17.7.4 and 17.8 prior to 17.8.2 that allows an attacker to execute unauthorized actions via a change page.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.6.5, 17.7.4, 17.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0376 or the next vulnerability affects your stack