What’s Vulnerable › Vulnerabilities
CVE-2025-0428: AI Power: Complete AI Pack <= 1.8.96 - Authenticated (Admin+) PHP Object Injection via wpaicg_export_prompts
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-22 · updated 2026-06-17
- Weakness: CWE-502
Description
The "AI Power: Complete AI Pack" plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 1.8.96 via deserialization of untrusted input from the $form['post_content'] variable through the wpaicg_export_prompts function. This allows authenticated attackers, with administrative privileges, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- senols AI Puffer – Your AI engine for WordPress (formerly AI Power): before 1.8.97 — fixed in 1.8.97
How to fix
Upgrade to a fixed version: senols AI Puffer – Your AI engine for WordPress (formerly AI Power) 1.8.97. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3224162/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/66a3abc1-0508-4ce3-952b-7dbf3738879a?source=cve
Get alerted when CVE-2025-0428 or the next vulnerability affects your stack