What’s Vulnerable › Vulnerabilities
CVE-2025-0470: Forminator <= 1.38.2 - Reflected Cross-Site Scripting via Title Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The Forminator Forms – Contact Form, Payment Form & Custom Form Builder plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the title parameter in all versions up to, and including, 1.38.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder: before 1.38.3 — fixed in 1.38.3
How to fix
Upgrade to a fixed version: wpmudev Forminator Forms – Contact Form, Payment Form & Custom Form Builder 1.38.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/forminator/tags/1.38.2/requirejs/main.js
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3226716%40forminator%2Ftrunk&old=3222217%40forminator%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f5281d4b-c2cd-4972-b837-e101a8893c6e?source=cve
Get alerted when CVE-2025-0470 or the next vulnerability affects your stack