What’s Vulnerable › Vulnerabilities

CVE-2025-0475: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 15.10 prior to 17.7.6, 17.8 prior to 17.8.4, and 17.9 prior to 17.9.1. A proxy feature could potentially allow unintended content rendering leading to XSS under specific circumstances.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.7.6, 17.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0475 or the next vulnerability affects your stack