What’s Vulnerable › Vulnerabilities
CVE-2025-0501: Issue affecting Amazon WorkSpaces Clients (when running PCoIP protocol)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue in the native clients for Amazon WorkSpaces (when running PCoIP protocol) may allow an attacker to access remote sessions via man-in-the-middle.
Affected products
- Amazon WorkSpaces Client: from 3.0.0 before 5.22.1; from 3.0.0 before 2024.6; from 3.0.1 before 5.0.1 — fixed in 2024.6, 5.0.1, 5.22.1
How to fix
Upgrade to a fixed version: Amazon WorkSpaces Client 2024.6, 5.0.1, 5.22.1. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/AWS-2025-001/
- https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-android-client.html#android-release-notes
- https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-linux-client.html#linux-release-notes
- https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-osx-client.html#osx-release-notes
- https://docs.aws.amazon.com/workspaces/latest/userguide/amazon-workspaces-windows-client.html#windows-release-notes
Get alerted when CVE-2025-0501 or the next vulnerability affects your stack