What’s Vulnerable › Vulnerabilities
CVE-2025-0512: Structured Content (JSON-LD) #wpsc <= 1.6.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via sc_fs_local_business Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Structured Content (JSON-LD) #wpsc plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's sc_fs_local_business shortcode in all versions up to, and including, 6.4.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Gordon Böhme, Antonio Leutsch Structured Content (JSON-LD) #wpsc: before 1.6.4 — fixed in 1.6.4
How to fix
Upgrade to a fixed version: Gordon Böhme, Antonio Leutsch Structured Content (JSON-LD) #wpsc 1.6.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/structured-content/trunk/templates/shortcodes/local-business.php#L10
- https://plugins.trac.wordpress.org/changeset/3248930/
- https://wordpress.org/plugins/structured-content/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8ac5fe69-7885-4fb7-8107-079216d6955e?source=cve
Get alerted when CVE-2025-0512 or the next vulnerability affects your stack