What’s Vulnerable › Vulnerabilities
CVE-2025-0513
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-79
Description
In affected versions of Octopus Server error messages were handled unsafely on the error page. If an adversary could control any part of the error message they could embed code which may impact the user viewing the error message.
Affected products
- Octopus Deploy Octopus Server: from 2024.3.164 before 2024.3.12985; from 2024.4.401 before 2024.4.6962 — fixed in 2024.3.12985, 2024.4.6962
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.3.12985, 2024.4.6962. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0513 or the next vulnerability affects your stack