What’s Vulnerable › Vulnerabilities

CVE-2025-0516: Incorrect Authorization in GitLab

Description

Improper Authorization in GitLab CE/EE affecting all versions from 17.7 prior to 17.7.4, 17.8 prior to 17.8.2 allow users with limited permissions to perform unauthorized actions on critical project data.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.7.4, 17.8.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0516 or the next vulnerability affects your stack