What’s Vulnerable › Vulnerabilities
CVE-2025-0525
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-200
Description
In affected versions of Octopus Server the preview import feature could be leveraged to identify the existence of a target file. This could provide an adversary with information that may aid in further attacks against the server.
Affected products
- Octopus Deploy Octopus Server: from 2020.6.4592 before 2024.3.13007; from 2024.4.401 before 2024.4.6995 — fixed in 2024.3.13007, 2024.4.6995
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.3.13007, 2024.4.6995. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0525 or the next vulnerability affects your stack