What’s Vulnerable › Vulnerabilities
CVE-2025-0539
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-10 · updated 2026-06-17
- Weakness: CWE-918
Description
In affected Microsoft Windows versions of Octopus Deploy, the server can be coerced into sending server-side requests that contain authentication material allowing a suitably positioned attacker to compromise the account running Octopus Server and potentially the host infrastructure itself.
Affected products
- Octopus Deploy Octopus Server: from 2.6.0 before 2024.3.13071; from 2024.4.401 before 2024.4.7065 — fixed in 2024.3.13071, 2024.4.7065
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.3.13071, 2024.4.7065. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0539 or the next vulnerability affects your stack