What’s Vulnerable › Vulnerabilities

CVE-2025-0555: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

A Cross Site Scripting (XSS) vulnerability in GitLab-EE affecting all versions from 16.6 prior to 17.7.6, 17.8 prior to 17.8.4, and 17.9 prior to 17.9.1 allows an attacker to bypass security controls and execute arbitrary scripts in a users browser under specific conditions.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.7.6, 17.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0555 or the next vulnerability affects your stack