What’s Vulnerable › Vulnerabilities
CVE-2025-0589
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-648
Description
In affected versions of Octopus Deploy where customers are using Active Directory for authentication it was possible for an unauthenticated user to make an API request against two endpoints which would retrieve some data from the associated Active Directory. The requests when crafted correctly would return specific information from user profiles (Email address/UPN and Display name) from one endpoint and group information ( Group ID and Display name) from the other. This vulnerability does not expose data within the Octopus Server product itself.
Affected products
- Octopus Deploy Octopus Server: from 2020.3.3 before 2024.3.13071; from 2024.4.401 before 2024.4.7065 — fixed in 2024.3.13071, 2024.4.7065
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.3.13071, 2024.4.7065. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0589 or the next vulnerability affects your stack