What’s Vulnerable › Vulnerabilities
CVE-2025-0593: SICK Lector8xx and InspectorP8xx vulnerable for code execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-14 · updated 2026-06-17
- Weakness: CWE-77
Description
The vulnerability may allow a remote low priviledged attacker to run arbitrary shell commands by using lower-level functions to interact with the device.
Affected products
- SICK AG SICK InspectorP8xx: before 3.11.1 — fixed in 3.11.1
- SICK AG SICK Lector8xx: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: SICK AG SICK InspectorP8xx 3.11.1; SICK AG SICK Lector8xx 2.4.0. Check the vendor advisory for mitigations.
References
- https://cdn.sick.com/media/docs/1/11/411/Special_information_CYBERSECURITY_BY_SICK_en_IM0084411.PDF
- https://sick.com/psirt
- https://www.cisa.gov/resources-tools/resources/ics-recommended-practices
- https://www.first.org/cvss/calculator/3.1
- https://www.sick.com/.well-known/csaf/white/2025/sca-2025-0002.json
- https://www.sick.com/.well-known/csaf/white/2025/sca-2025-0002.pdf
Get alerted when CVE-2025-0593 or the next vulnerability affects your stack