What’s Vulnerable › Vulnerabilities

CVE-2025-0605: Weak Authentication in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 16.8 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Group access controls could allow certain users to bypass two-factor authentication requirements.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.10.7, 17.11.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0605 or the next vulnerability affects your stack