What’s Vulnerable › Vulnerabilities
CVE-2025-0628: Improper Authorization in BerriAI/litellm
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-266
Description
An improper authorization vulnerability exists in the main-latest version of BerriAI/litellm. When a user with the role 'internal_user_viewer' logs into the application, they are provided with an overly privileged API key. This key can be used to access all the admin functionality of the application, including endpoints such as '/users/list' and '/users/get_users'. This vulnerability allows for privilege escalation within the application, enabling any account to become a PROXY ADMIN.
Affected products
- BerriAI litellm: before v1.61.15-nightly — fixed in v1.61.15-nightly
How to fix
Upgrade to a fixed version: BerriAI litellm v1.61.15-nightly. Check the vendor advisory for mitigations.
References
- https://github.com/berriai/litellm/commit/566d9354aab4215091b2e51ad0333e948125fa1b
- https://huntr.com/bounties/6c0e2f75-2d03-42f9-9530-e16a973317fc
Get alerted when CVE-2025-0628 or the next vulnerability affects your stack