What’s Vulnerable › Vulnerabilities

CVE-2025-0652: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE/CE affecting all versions starting from 16.9 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2 could allow unauthorized users to access confidential information intended for internal use only.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.7.7, 17.8.5, 17.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0652 or the next vulnerability affects your stack