What’s Vulnerable › Vulnerabilities

CVE-2025-0661: DethemeKit For Elementor <= 2.1.8 - Authenticated (Contributor+) Protected Post Disclosure

Description

The DethemeKit For Elementor plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 2.36 via the duplicate_post() function due to insufficient restrictions on which posts can be duplicated. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from password protected, private, draft, or scheduled posts that they should not have access to by duplicating the post.

Affected products

How to fix

Upgrade to a fixed version: DethemeKit For Elementor 2.1.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-0661 or the next vulnerability affects your stack